Categories
WP Plugin Setup

System Requirements

Website Requirements for Slibstream

Slibstream requires 1. and 2. (3. is optional):

  1. Self hosted WordPress website
  2. WooCommerce plugin installed
  3. (Optional) WordPress Multi Language [WPML]

What is a “Self hosted WordPress website”?

In a nutshell, self hosting your WordPress site means downloading your own copy of the WordPress content management system (CMS), finding a domain provider, and signing up for a hosting service to host your site on the Internet

Colorlib.com

Slibstream is designed to run on self hosted WordPress websites running the WooCommerce plugin. WPML is optional. Our demo self hosted WordPress shop runs WooCommerce with WPML.

API Key Requirements for Slibstream

Slibstream is a paid (premium) service. Find your API key here or create an account to use Slibstream.

Slibstream requires a valid API key to function.

PHP Version Requirements for Slibstream

Slibstream has been tested on PHP 7.3 + PHP 7.4.

It is unlikely that Slibstream will run on PHP 5.X because it is no longer supported.

PHP 7.0, PHP 7.1, PHP 7.2 have security fixes.

It is therefore recommended that you run Slibstream on PHP 7.3 or PHP 7.4.

WordPress and WooCommerce Version Requirements

We aim to keep Slibstream running and functioning correctly on the latest versions of WordPress, WooCommerce and WPML.

It is unlikely Slibstream will work if you are running outdated versions these plugins.